1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

minecraft.jar

Discussion in 'General' started by Eraisuithon134, Apr 1, 2012.

  1. For some reason when i try to make the minecraft.jar file into a folder via the Mac's archive utility it turns it into a .cpgz file instead of a folder. It never did this before 1.2.4 and i haven't been able to use mods because of it. I tried renaming minecraft.jar into a .zip file and that worked but once i installed the mods it made minecraft crash. I tried it several more times to make sure that i didn't just install the mods incorrectly and it still crashed. If any of you know how to fix this i'd greatly appreciate it.
  2. Let me see if I understand this correctly...
    You have a mac, and your trying to mod your .jar in the bin in minecraft to install mods. And when u try to "open" the jar/make it a folder, it doesn't work?

    Well here's what i do: (i have a mac)
    go to you .jar and right click it, and choose open with archive utility- it should open a copy of it as a folder. Delete the original and add the extension .jar to the end of it. Now you can start modding!

    If that doesn't work I would suggest downloading the unarchiver (link at bottom) and doing the same thing but open with the unarchiver instead of archive utility.
    Hope that helps! lmk if it works or not, and what the problem is.

    The unarchiver: http://unarchiver.c3.cx/
  3. I know that, what I'm trying to say is that since 1.2.4 the archive utility turns minecraft.jar into a minecraft.cpgz file instead of a folder. Ill try the unarchiver.
  4. Huh. just tried it with my 1.2.4 worked fine with archive utility, but yeah, let me know if the unarchiver works.
  5. Or just mod with the terminal...
  6. Ron, are you using OSX Lion or Leopard? I'm using leopard.